Студопедия

Главная страница Случайная лекция


Мы поможем в написании ваших работ!

Порталы:

БиологияВойнаГеографияИнформатикаИскусствоИсторияКультураЛингвистикаМатематикаМедицинаОхрана трудаПолитикаПравоПсихологияРелигияТехникаФизикаФилософияЭкономика



Мы поможем в написании ваших работ!




Вопрос №3. Синтаксис языка 1С

Читайте также:
  1. III. Борьба за разрешение восточного вопроса.
  2. IV. ОФИЦИАЛЬНО-ДЕЛОВОЙ СТИЛЬ СОВРЕМЕННОГО РУССКОГО ЯЗЫКА.
  3. А). Вопрос об «асимметрии правил допустимости доказательств» (или возможности использования доказательств, полученных с нарушением закона, стороной защиты).
  4. Б). Решение вопроса об исключении доказательств, в зависимости от характера допущенного нарушения.
  5. Базовый синтаксис С#. Структура программы
  6. ВВОДНЫЙ КУРС НЕМЕЦКОГО ЯЗЫКА
  7. Виды вопросов
  8. Виды решений, принимаемых по результатам рассмотрения вопроса о допустимости доказательств.
  9. Вопрос - 2. Самозащита гражданских прав.
  10. Вопрос 1 Понятие и значение состава преступления.

Язык 1С очень похож на Бейсик. В 1С все ключевые слова можно писать по-русски.

Конструкция языка 1С Примечание
Процедура РассчитатьНалог(Сотрудник, НекаяДата) КонецПроцедуры Простая процедура. После слова КонецПроцедуры точка с запятой не нужна, потому что это не оператор, а операторная скобка
Функция РассчитатьНалог(Сотрудник, НекаяДата) Возврат Налог; КонецФункции Функция должна обязательно возвращать результат.
Если Оклад > 10000 Тогда КонецЕсли; Простое условие. После слова КонецЕсли должна быть точка с запятой, потому что так заканчивается оператор Если
Результат = ?(Оклад > 10000, "Нормально","Плохо"); Сокращенное Если.
Если (Оклад > 10000) И (КодКатегории = 2) Тогда КонецЕсли; В составном логическом выражении скобки обязательны!
Пока Номер <= 50 Цикл КонецЦикла; Простой цикл Пока (цикл с неизвестным числом повторений). После слова КонецЦикла должна быть точка с запятой, потому что так заканчивается оператор Пока
Для Номер = 1 По 50 Цикл КонецЦикла; Простой цикл Для (цикл с известным числом повторений).
Перейти ~метка; <...> ~метка: Так оформляются метки и оператор безусловного перехода (GOTO). Чем меньше в вашей программе будет меток, тем лучше.
Пока <условие> Цикл Если <условие> Тогда ........Продолжить; КонецЕсли; КонецЦикла; Оператор Продолжить передает управление в начало цикла.
Пока <условие> Цикл Если <условие> Тогда .........Прервать; КонецЕсли; КонецЦикла; Оператор Прервать производит досрочный выход из цикла. Управление передается на операторы после цикла.
Перем Сотр; Явное объявление переменной.
Номер = 1; Переменные можно не объявлять явно. При первом присвоении значения создается новая переменная.
ФИО = Фамилия + " " + Имя + " " + Отчество; Сложение строк (конкатенация)
НекаяДата = '01.01.2002'; Переменная, которая хранит дату.
Перем глТекущийПользователь Экспорт; Объявление глобальной переменной в Глобальном модуле. Такие переменные доступны в любом месте конфигурации.
Попытка а = 10 / 0; Исключение Предупреждение("Деление на ноль!"); КонецПопытки; Обработка исключительных ситуаций. Если во время выполнения операторов между словами Попытка и Исключение произошла ошибка, то управление передается на операторы между словами Исключение и КонецПопытки Если ошибки не было, то управление передается на операторы после слова КонецПопытки.
//это комментарий Так оформляются комментарии.
СпрСотр.ВыбратьЭлементы(); Вызов метода объекта производится как обычно, через точку.

 

И так, сегодня мы ознакомились с назначением языка «1С» и синтаксисом встроенного языка, рассмотрели виды программных модулей.

Вопросы, связанные с построением и видами запросов, рассмотрим на следующей лекции.

Использованная для подготовки лекции литература



 

1. Введение в конфигурирование в системе «1С: Предприятие 8». Основные объекты. Версия 8.2. Фирма «1С», Москва, ООО «1С-Учебный центр№3», 2010.

2. 1С: Предприятие 8.2. Руководство разработчика. Часть 1. Фирма «1С», Москва, ООО «1С-Учебный центр№3», 2009.

3. 1С: Предприятие 8.2. Руководство разработчика. Часть 2. Фирма «1С», Москва, ООО «1С-Учебный центр№3», 2009.

 

Доцент кафедры АСУ

Т.Авакян


<== предыдущая страница | следующая страница ==>
Системные процедуры и функции | Турбулентное течение. Полуэмпирическая теория турбулентности

Дата добавления: 2014-07-19; просмотров: 593; Нарушение авторских прав




Мы поможем в написании ваших работ!
lektsiopedia.org - Лекциопедия - 2013 год. | Страница сгенерирована за: 0.003 сек.